Не работает модель? - Вам сюда!

» опубликован
Данная тема предназначена для того, чтобы оставлять здесь просьбы об исправлении багов/недочётов/ошибок в модели или её доработке, а также исправлении неработоспособности модели в игре.

Правила

Структура любой заявки должна быть такова:
  1. Краткое описание модели;
  2. Чёткое, ясное и конкретное описание проблемы, возникшей с моделью;
  3. Ваши собственные попытки решения проблемы;
  4. По возможности приложите изображение вашей проблемы (например, скриншот ошибки);
  5. Приложение файла-модели обязательно;
  6. Прочее (сроки выполнения, пожелания, заметки и т. д.).
  • Запрещено повторение заявок; повторные заявки будут удаляться.
  • Заявки типа "модель непашит в редакторе. испрвьте" будут удаляться.
  • Заявки без приложенной модели тоже будут удаляться.
  • Если вы уверены, что импортировали модель верно, соблюдая все пути, но модель не работает (т.н. "зелёный куб"), к заявке прилагать скриншот (помните о картинках во вложениях: не более 500 Кб, если больше - на хостинг) из менеджера импорта и ReadMe (или какой-нибудь утилиты, удостоверяющей пути) со всеми путями. Заявки такого типа без необходимых подтверждений, описанных в данном пункте, будут удаляться.
» Пример правильно оформленной заявки
Модель простого капкана, анимирована.
При проигрывании анимации Death, где-то между 333 и 467 кадрами, в модели происходит странное дёрганье, модель не является моей, и я при попытках исправить баг, только ухудшал ситуацию... Модель нужна срочно, пожалуйста исправьте этот баг в течение трёх дней.
И помните: всегда пробуйте решить проблему самостоятельно.
Тема не предназначена для написания вам путей текстур. Если данное простое дело не получается выполнить самостоятельно, следует внимательней перечитать статьи

 

Просмотров: 10 964



SomeFire #1 - 7 лет назад 1
  1. Паровой голем
  2. Вылетает крит при выделении юнита с данной моделью.
  3. Скачал заново и запихнул в карту - результат тот же.
  4. крит как крит:
Exception: 0xC0000005 (ACCESS_VIOLATION) AT 001B:6F4DE1E0
The instruction at '0x6F4DE1E0' referenced memory at ' 0x0000000C'
  1. xgm.ru/p/wc3/3894
  2. Не горит, но чем раньше, тем лучше.
JesusHipster #2 - 7 лет назад (отредактировано ) 0
Буду разбираться>_>
Исправил и обновил саму модель, спасибо за фидбек, пусть и спустя 5 лет:)
Yarjikk #3 - 7 лет назад (отредактировано ) 0
Дренеи-лучница и асассин не работают.Пробовал удалить путь в редакторе,сохранял их и запускал заново.Не работает...
Зелёный куб и все...
прикреплены файлы
JesusHipster #4 - 7 лет назад 0
Yarjikk, Всё должно прекрасно работать. Это модель с хайва, а там как и тут проверяется работоспособность модели в игре т.е. это твой фейл.
Jusper #5 - 7 лет назад (отредактировано ) 0
Модель персонажа из проекта Дюна, автор fall
В W3ME все анимации нормальные, но при загрузке в WE, анимации Stand, Walk Defend не проигрываются. Вместо этого модель расставляет руки-ноги и скользит по земле. При загрузке, если эта модель присутствует на карте вылетает ошибка. Иногда сталкивался с такой проблемой но не знаю как решить, если она является типовой, прошу дать консультацию по ее устранению.
прикреплены файлы
afiloss #6 - 7 лет назад 0
подскажите программу для просмотра моделей
Dima665 #7 - 7 лет назад 0
Вот модель не загружается в редакторе,что делать?
Гаутама Будда #8 - 7 лет назад 0
Как только хочу сменить модельку редактор вылетает. Помогите!
прикреплены файлы
Хенк #9 - 7 лет назад 0
В модели 5 материалов, ко всем нужно применить анимацию текстур (она там одна)
пробовал по статье через блокнот но видимо чтото неправильно делал
хотелось бы узнать решение
не срочно
прикреплены файлы
Daro #10 - 7 лет назад 1
Кто может модели доработать.чтоб был чест и лицо в окошке?
Nordunger #11 - 4 года назад 0
Пожалуйста, почините модель. Модель броне-слона в игре дичайше пестрит... Не знаю как это точнее выразить словами... По экрану вокруг модели во время игры судорожно летают большие куски текстур. А в MdlVis всё выглядит нормально.
прикреплены файлы
Nordunger #12 - 4 года назад 0
Nordunger:
Пожалуйста, почините модель. Модель броне-слона в игре дичайше пестрит... Не знаю как это точнее выразить словами... По экрану вокруг модели во время игры судорожно летают большие куски текстур. А в MdlVis всё выглядит нормально.
Ну или подскажите как это убрать самостоятельно, а то я в тыр-нете ничегошеньки не нашёл на тему подобных глюков с моделями!
Nordunger #13 - 4 года назад 0
Модель катапульты отрёкшихся из WOW - колёса не крутятся во время анимации движения ! Пожалуйста, добавьте анимацию вращения колёс, очень нужно! Пожалуйста!
прикреплены файлы
Darknessay #14 - 3 года назад 0
Вылетает редактор при попытке поставить юниту с развернутым главным окном(т.е. при попытке отобразить модель).
Я пробовал сохранять mdx>mdl>mdx.
(Да, я их менял, это какая то лажа с MdlVis'ом)
прикреплены файлы
EvilPenguin #15 - 3 года назад (отредактировано ) 0
Собственно модель взята с самого сайта xgm) Модель гнома в черной шляпе именно она мне нужна. При выборе её в редакторе редактор перестает отвечать и вылетает ( сообщения об ошибки нет ). Модель я не менял. Пробовал переписать путь к текстурам не помогло.
Darknessay #16 - 3 года назад (отредактировано ) 0
  1. Экспорт из "Метро".
  2. Крит при загрузке(на второй половине полоски, если это важно), если юнит стоит на карте.
  3. Удалил лишние анимки, но думаю дело в костях(не брался за это), т.к. был опыт.
4)
  1. Достаточно срочно...
прикреплены файлы
хИНКОГНИТОх #17 - 1 год назад 0
  1. Эонар
  2. Модель не отображается в редакторе и, собственно, в игре
  3. Путь был прописан корректно, однако это не помогло
прикреплены файлы
ClotPh #18 - 1 год назад 0
вместо модели и ее портрета в игре отображается непонятно что (там модели две, но одна - ретекстур второй).
В мдлвисе и модел едиторе все великолепно... прошу помочь
/ Просьба актуальна до завтрашнего утра, иначе уже не сильно нужно
ledoed #19 - 1 год назад (отредактировано ) 0
хИНКОГНИТОх:
  1. Эонар должна работат(в игре не проверял)
прикреплены файлы
Versus6 #20 - 1 год назад 0
Глючит редактор изза модели, помогите пожалуйста
нехочет открываться
прикреплены файлы
ene241 #21 - 1 год назад 0
1)Гоблин в роботе-пулемёте.
2)Проблемы с выделением юнита.
3)Пробовал менять коллизию через модельэдитор в Windows/Node Manager, однако это не она виновата. Даже если полностью удалить кубик с коллизией, юнит продолжит выделяться и выделяться неправильно.
В моделлинге не шарю, скачал в интернете. Пулемёт нужен не срочно. Кстати, когда я конвертнул модель из mdx в mdl, баг слегка поменялся. При обратном конвертировании вернулся в изначальное состояние. Скрин и модель прилагаются.
прикреплены файлы
Maniac_91 #22 - 1 год назад 0
ene241, попробуй рассчитать границы в War3 Model Editor.
ene241 #23 - 1 год назад 0
Maniac_91, не помогло, ровно также выделяется
Коля6 #24 - 1 год назад 0
король лич нерзул зелёный куб в игре тень
пойму только в видосе
loliconshik3 #25 - 1 год назад 0
модель Рем
при загрузке карты с данной моделью вылетает we
loliconshik3:
модель Рем
при загрузке карты с данной моделью вылетает we
пытался что-нибудь сделать в mdvls но т.к. ничего в этом не понимаю, сделал только хуже
прикреплены файлы
Desgul #26 - 1 год назад 0
Кто может сделать collision shapes, трудно навести на модельку мышкой
прикреплены файлы
8gabriel8 #27 - 1 год назад 0
Andrey33:
Кто может сделать collision shapes, трудно навести на модельку мышкой
Сейчас проверил, нормально модель выделяется и лечится. Может в РО ей какие-то значения так поменял? Для проверки заменил ею модель Чародея крови.
ClotPh #28 - 1 год назад (отредактировано ) 0
8gabriel8, мной не качалось и не проверялось, но ты во всех возможных ситуациях смотрел? Часто на модель трудно навести, например, в движении или атаке юнита
8gabriel8 #29 - 1 год назад 0
ClotPh, да, нормально. И такое простым пересчётом границ решается же.
Desgul #30 - 1 год назад (отредактировано ) 0
ClotPh, Особенно в движение.
Например вот эта модель отлично сделана
у лучницы выбор <----> у воина <----------> разница огромная
я проверял на рексаре думал он же большой=)
прикреплены файлы
ledoed #31 - 1 год назад (отредактировано ) 0
Andrey33:
нужно сделать перерасчет по мешу,делаеть в модель едиторе
Desgul #32 - 1 год назад 0
ledoed, если бы я умел делать я бы не обращался сюда
ledoed #33 - 1 год назад 2
Andrey33:
ledoed, если бы я умел делать я бы не обращался сюда
починил
прикреплены файлы
Desgul #34 - 1 год назад 0
ledoed, Спасибо большое
Desgul #35 - 1 год назад 0
Сделайте пожалуйста анимацию атаки с луком, а то махает мечом и стрела вылетает, а еще если можно удалите не нужные анимации и удалить меч вообще.
прикреплены файлы
biridius #36 - 1 год назад (отредактировано ) 1
Andrey33, там же есть две анимации shoot, только и надо что переименовать в Attack, а атакам мечом поставить тег alternate или удалить
прикреплены файлы
Desgul #37 - 1 год назад (отредактировано ) 0
biridius, Спасибо, а как сделать что бы лук был всегда при ней, просто в игре она совсем без лука, только меч весит
biridius #38 - 1 год назад (отредактировано ) 1
Andrey33, придется рисовать новую ходьбу, стояние с луком есть, щас мб сделаю
надо проверять, вот новая анимация ковыляния, и старое стояние теперь с тегом Alternate, так что должны проигрываться анмации с луком которые Stand Ready
вот, поправил стояние
прикреплены файлы
Desgul #39 - 1 год назад 0
biridius, Спасибо, только она теперь бегает как крадётся и тогда только у ней лук появляется а когда стоит его нету
BattleMaster #40 - 1 год назад 0
День добрый, не работает модель зилота со священного(тм) воркшопа. Классика: в редакторе куб, в игре - тень.
Качал аналогичные модели с двух сайтов (с вышеупомянутого Воркшопа и с прибежища Сатаны), удалял, импортировал, и повторял все еще несколько раз. Итог - тень и куб.
Модель нужна в кратчайшие строки.
прикреплены файлы
8gabriel8 #41 - 1 год назад 0
BattleMaster, наверное, что-то не так выставил в РО. Всё нормально отображается:
прикреплены файлы
BattleMaster #42 - 1 год назад (отредактировано ) 0
8gabriel8:
BattleMaster, наверное, что-то не так выставил в РО. Всё нормально отображается:
хм... я заново удалил все протосское, импортировал зилота. все заработало. Импортировал модель врат, снова что-то сломалось. Может, я лучше пришлю карту?
О, теперь и смысл карты - нексус сломался
прикреплены файлы
8gabriel8 #43 - 1 год назад 0
BattleMaster, проблемы с текстурами для зилота и врат скорее всего потому, что импортировал одни и те же файлы поверх других. Так не надо делать, если текстура уже есть, то не импортируй её снова. А для нексуса не хватает текстуры ProtossGlow1.blp.
BattleMaster #44 - 1 год назад 0
8gabriel8:
BattleMaster, проблемы с текстурами для зилота и врат скорее всего потому, что импортировал одни и те же файлы поверх других. Так не надо делать, если текстура уже есть, то не импортируй её снова. А для нексуса не хватает текстуры ProtossGlow1.blp.
Так... и как починить пилон, врата и зилота?
8gabriel8 #45 - 1 год назад 0
Давай-ка ты мне сам ответишь на этот умный вопрос!)
BattleMaster, помоги! Неправильно импортировал пилон, врата и зилота, что же теперь делать?
BattleMaster #46 - 1 год назад 0
8gabriel8:
Давай-ка ты мне сам ответишь на этот умный вопрос!)
BattleMaster, помоги! Неправильно импортировал пилон, врата и зилота, что же теперь делать?
Логично предположить, что нужно правильно импортировать файлы, но есть одна проблема... Я не знаю. какие из них создают проблемы. Двойные файлы, если что, я уже удалил.
8gabriel8 #47 - 1 год назад 0
BattleMaster, просто импортируй файлы по-одному, если файл уже есть, то повторно не импортируй. Проще всего, если ты ПОЛНОСТЬЮ удалил файлы, скопировать файлы из папок с зилоном, вратами и нексусом в одну, а её целиком импортировать.
Ургаш #48 - 11 месяцев назад (отредактировано ) 0
1.Модель Алекстразы из HotS
2.Зелёный кубик
3.Добавление к файлу "blp" надписи textures\
4.В прикреплённых файлах (Skrin)
5.В прикреплённых файлах (alexstrsza.mdx .blp)
6.Сам архив warcraftunderground.freeforums.net/thread/497/all-rips-little-up...(слишком здоровый чтобы прикреплять) откуда я это выдрал, но не думаю что он поможет.
прикреплены файлы
8gabriel8 #49 - 11 месяцев назад (отредактировано ) 2
прикреплены файлы
Ургаш #50 - 11 месяцев назад 0
textures\
Спасибо! Либо архив обновили, либо я неправильно textures\ прописывал.
Adantarn #51 - 11 месяцев назад 0
Модель с этого сайта, Эльфийка крови - лучница
Вылет игры с ошибкой.
прикреплены файлы
vovana123 #52 - 9 месяцев назад (отредактировано ) 0
  1. Модель Хинаты (из аниме Наруто)
  2. В игре модель не видно, тупо пустота и все((
  3. в мдвиле модельку видно, а в игре нет, не знаю даже в чем дело*(((
Ссылка на саму модель - my-files.ru/kye32v
bazeba #53 - 9 месяцев назад 0
vovana123:
  1. Модель Хинаты (из аниме Наруто)
  2. В игре модель не видно, тупо пустота и все((
  3. в мдвиле модельку видно, а в игре нет, не знаю даже в чем дело*(((
Ссылка на саму модель - my-files.ru/kye32v
написал уже там
Desgul #54 - 8 месяцев назад 0
Кто может добавить анимацию смерти
вот этой модельке
прикреплены файлы
Diazon #55 - 6 месяцев назад (отредактировано ) 0
Всем привет!
Делаю Техножреца на пауканских ножках из Warhammer 40000 (в процессе)
Делал с помощью MatrixEater. Отображается в War3model Editore и Mdlvis-е, однако в игре и редакторе модель не отображается
Зеленый квадрат в редакторе и тень при запуске карты.
Может кто помочь?
прикреплены файлы
homl #56 - 5 месяцев назад (отредактировано ) 0
что мне делать если вот такое с моделькой.как исправить (Прикрепил изображение)
модель и фото
кто сможет почените
И текстури
что мне делать если вот такое с моделькой.как исправить (Прикрепил изображение)
модель и фото
прикреплены файлы
Proshel_Doty #57 - 5 месяцев назад 0
Модель конеш не отсюда, но
Короче у меня в карте не работает, хотя В3МЕ открывает и импортируемых текстур там нет
У кого она работает? Знает кто в чём дело?
homl #58 - 5 месяцев назад (отредактировано ) 0
что мне делать если вот такое с моделькой.как исправить (Прикрепил изображение)
модель и фото
кто сможет почените
И текстури
что мне делать если вот такое с моделькой.как исправить (Прикрепил изображение)
модель и фото
прикреплены файлы
SNART #59 - 5 месяцев назад (отредактировано ) 1
homl:
что мне делать...
Прикрепить ещё текстуры.
прикреплены файлы
8gabriel8 #60 - 5 месяцев назад 1
Ого, так там огромное здание! Мне казалось, что там просто какой-то особенный дирижабль)
homl #61 - 5 месяцев назад 0
SNART:
homl:
что мне делать...
Прикрепить ещё текстуры.
вот
архивирование
прикреплены файлы
8gabriel8 #62 - 5 месяцев назад (отредактировано ) 1
Ссылка на архив, так как с трудом до него докопался.

Похоже, это не совсем то, что мне казалось. У меня периодически так мигает.
Появляются не просто странные объекты около модели, а текстура земли взрывается. Может быть видеокарта слабая, чтобы данные от движка переварить, так как у нас визуально различаются глюки, а может быть сам старый движок игры не справляется с обработкой такого количества вершин, в любом случае вряд ли что-то поможет, лучше поискать альтернативу.
прикреплены файлы
Феникс #63 - 5 месяцев назад 1
100к вершин и на выходе такое убожество...
homl #64 - 5 месяцев назад 0
Большое спасибо
как уменшить
Феникс #65 - 5 месяцев назад 1
homl, Да адекватными способами никак, лучше отказаться от этой модели, она вообще не уместна в варкрафте
homl #66 - 5 месяцев назад 0
Большое спасибо
Araders #67 - 5 месяцев назад 0
PrincePhoenix, Если я не ошибаюсь то это какой-то корабль дренеев из WoW. Сетка просто ужасная, такое чувство что это какой-то плагин или функция по ретопологии так поиздевались.
valvesguns #68 - 3 месяца назад 0
Модель Халлази
Не работает в карте, хоть все текстуры правильно указал.
Я попытался исправить что-то в mdlvis, но так как я там нуб, это не помогло ((
Помогите пожалуйста.
McLaren0109 #69 - 3 недели назад 0
Проблема довольно редкая, у меня возникла повторно. Модель не выбирается в игре, либо выбирается только при определенном угле поворота. Ни узлы форм, ни "рассчитать границы" не помогают. Кроме того, не виден портрет юнита, хотя камера есть (есть или нет анимация portrait тоже не меняет ничего).
Ну официально такая штука пыталась решиться на примере вот этой модели:
Скачал вот такую модель авиации:
Когда решил добавить сюда новые анимации, возникла точно такая же беда.
Портрет пропал, модель практически не выбираема. Точка выбора смещается на юг игровой карты примерно на 500 warcraft'ных единиц расстояния. В той модели, что я прикрепил portrait не доделан, я просто убедился, что портрет модели так и не появился... Границы рассчитывал многократно
прикреплены файлы
poisoNDealer #70 - 3 недели назад (отредактировано ) 1
McLaren0109, а в чём задача вот этой поверхности и связанных с ней эффектов? xgm.guru/files/temp/61216/fd63350d97664ebaada07b375fdbd00d.jpg
Скорее всего из-за её присутствия в модели, границы неправильно рассчитываются, так как даже если в модели по ссылке рассчитать их через war3me, то вылезают те же проблемы. Если, соответственно, её удалить, а заодно и все связанные с ней анимации поверхности и эффекты (чтобы модель не фаталила), и перерасчитать границы, то модель становится выделяемой в игре, и портрет работает.
Честно говоря, кроме метода выше, с удалением поверхности, другого способа починки не нашёл. Пробовал вручную вводить границы, возвращал со старой модели, придумывал новые, баловался с коллизией, но видимого результата это вообще не принесло, прям магия какая-то. Хотя теоретически всё должно заработать, но почему-то не получилось.
Собственно, вот модель,с удалёнными эффектами и анимациями поверхности, которая нормально работает в игре
прикреплены файлы
McLaren0109 #71 - 3 недели назад 0
poisoNDealer, благодарю вас! Этот материал и поверхность возникают при анимации смерти. Один в начале анимации, второй в конце, когда авиация падает на землю и взрывается. Попробую заменить материал и поверхность на излучатель частиц 2. Возможно такая же беда случилась и с моделью космического пехотинца.
Abdurasul #72 - 2 недели назад 0
Здраствуйте!
  1. DotA - Shadow Fiend
  2. Уменя не работает сф модель для доты.
  3. я все сделал
8gabriel8 #73 - 2 недели назад 0
Abdurasul, у текстуры путь удалил?