Не работает модель? - Вам сюда!

» опубликован
Данная тема предназначена для того, чтобы оставлять здесь просьбы об исправлении багов/недочётов/ошибок в модели или её доработке, а также исправлении неработоспособности модели в игре.

Правила

Структура любой заявки должна быть такова:
  1. Краткое описание модели;
  2. Чёткое, ясное и конкретное описание проблемы, возникшей с моделью;
  3. Ваши собственные попытки решения проблемы;
  4. По возможности приложите изображение вашей проблемы (например, скриншот ошибки);
  5. Приложение файла-модели обязательно;
  6. Прочее (сроки выполнения, пожелания, заметки и т. д.).
  • Запрещено повторение заявок; повторные заявки будут удаляться.
  • Заявки типа "модель непашит в редакторе. испрвьте" будут удаляться.
  • Заявки без приложенной модели тоже будут удаляться.
  • Если вы уверены, что импортировали модель верно, соблюдая все пути, но модель не работает (т.н. "зелёный куб"), к заявке прилагать скриншот (помните о картинках во вложениях: не более 500 Кб, если больше - на хостинг) из менеджера импорта и ReadMe (или какой-нибудь утилиты, удостоверяющей пути) со всеми путями. Заявки такого типа без необходимых подтверждений, описанных в данном пункте, будут удаляться.
» Пример правильно оформленной заявки
Модель простого капкана, анимирована.
При проигрывании анимации Death, где-то между 333 и 467 кадрами, в модели происходит странное дёрганье, модель не является моей, и я при попытках исправить баг, только ухудшал ситуацию... Модель нужна срочно, пожалуйста исправьте этот баг в течение трёх дней.
И помните: всегда пробуйте решить проблему самостоятельно.
Тема не предназначена для написания вам путей текстур. Если данное простое дело не получается выполнить самостоятельно, следует внимательней перечитать статьи

 

Просмотров: 6 529

SomeFire #1 - 6 лет назад 1
  1. Паровой голем
  2. Вылетает крит при выделении юнита с данной моделью.
  3. Скачал заново и запихнул в карту - результат тот же.
  4. крит как крит:
Exception: 0xC0000005 (ACCESS_VIOLATION) AT 001B:6F4DE1E0
The instruction at '0x6F4DE1E0' referenced memory at ' 0x0000000C'
  1. xgm.ru/p/wc3/3894
  2. Не горит, но чем раньше, тем лучше.
JesusHipster #2 - 6 лет назад (отредактировано ) 0
Буду разбираться>_>
Исправил и обновил саму модель, спасибо за фидбек, пусть и спустя 5 лет:)
Yarjikk #3 - 6 лет назад (отредактировано ) 0
Дренеи-лучница и асассин не работают.Пробовал удалить путь в редакторе,сохранял их и запускал заново.Не работает...
Зелёный куб и все...
прикреплены файлы
JesusHipster #4 - 6 лет назад 0
Yarjikk, Всё должно прекрасно работать. Это модель с хайва, а там как и тут проверяется работоспособность модели в игре т.е. это твой фейл.
Jusper #5 - 6 лет назад (отредактировано ) 0
Модель персонажа из проекта Дюна, автор fall
В W3ME все анимации нормальные, но при загрузке в WE, анимации Stand, Walk Defend не проигрываются. Вместо этого модель расставляет руки-ноги и скользит по земле. При загрузке, если эта модель присутствует на карте вылетает ошибка. Иногда сталкивался с такой проблемой но не знаю как решить, если она является типовой, прошу дать консультацию по ее устранению.
прикреплены файлы
afiloss #6 - 6 лет назад 0
подскажите программу для просмотра моделей
Dima665 #7 - 6 лет назад 0
Вот модель не загружается в редакторе,что делать?
Гаутама Будда #8 - 6 лет назад 0
Как только хочу сменить модельку редактор вылетает. Помогите!
прикреплены файлы
Хенк #9 - 6 лет назад 0
В модели 5 материалов, ко всем нужно применить анимацию текстур (она там одна)
пробовал по статье через блокнот но видимо чтото неправильно делал
хотелось бы узнать решение
не срочно
прикреплены файлы
Daro #10 - 6 лет назад 1
Кто может модели доработать.чтоб был чест и лицо в окошке?
Nordunger #11 - 3 года назад 0
Пожалуйста, почините модель. Модель броне-слона в игре дичайше пестрит... Не знаю как это точнее выразить словами... По экрану вокруг модели во время игры судорожно летают большие куски текстур. А в MdlVis всё выглядит нормально.
прикреплены файлы
Nordunger #12 - 3 года назад 0
Nordunger:
Пожалуйста, почините модель. Модель броне-слона в игре дичайше пестрит... Не знаю как это точнее выразить словами... По экрану вокруг модели во время игры судорожно летают большие куски текстур. А в MdlVis всё выглядит нормально.
Ну или подскажите как это убрать самостоятельно, а то я в тыр-нете ничегошеньки не нашёл на тему подобных глюков с моделями!
Nordunger #13 - 3 года назад 0
Модель катапульты отрёкшихся из WOW - колёса не крутятся во время анимации движения ! Пожалуйста, добавьте анимацию вращения колёс, очень нужно! Пожалуйста!
прикреплены файлы
Darknessay #14 - 2 года назад 0
Вылетает редактор при попытке поставить юниту с развернутым главным окном(т.е. при попытке отобразить модель).
Я пробовал сохранять mdx>mdl>mdx.
(Да, я их менял, это какая то лажа с MdlVis'ом)
прикреплены файлы
EvilPenguin #15 - 2 года назад (отредактировано ) 0
Собственно модель взята с самого сайта xgm) Модель гнома в черной шляпе именно она мне нужна. При выборе её в редакторе редактор перестает отвечать и вылетает ( сообщения об ошибки нет ). Модель я не менял. Пробовал переписать путь к текстурам не помогло.
Darknessay #16 - 1 год назад (отредактировано ) 0
  1. Экспорт из "Метро".
  2. Крит при загрузке(на второй половине полоски, если это важно), если юнит стоит на карте.
  3. Удалил лишние анимки, но думаю дело в костях(не брался за это), т.к. был опыт.
4)
  1. Достаточно срочно...
прикреплены файлы
хИНКОГНИТОх #17 - 4 месяца назад 0
  1. Эонар
  2. Модель не отображается в редакторе и, собственно, в игре
  3. Путь был прописан корректно, однако это не помогло
прикреплены файлы
ClotPh #18 - 4 месяца назад 0
вместо модели и ее портрета в игре отображается непонятно что (там модели две, но одна - ретекстур второй).
В мдлвисе и модел едиторе все великолепно... прошу помочь
/ Просьба актуальна до завтрашнего утра, иначе уже не сильно нужно
ledoed #19 - 4 месяца назад (отредактировано ) 0
хИНКОГНИТОх:
  1. Эонар должна работат(в игре не проверял)
прикреплены файлы
Versus6 #20 - 3 месяца назад 0
Глючит редактор изза модели, помогите пожалуйста
нехочет открываться
прикреплены файлы
ene241 #21 - 2 месяца назад 0
1)Гоблин в роботе-пулемёте.
2)Проблемы с выделением юнита.
3)Пробовал менять коллизию через модельэдитор в Windows/Node Manager, однако это не она виновата. Даже если полностью удалить кубик с коллизией, юнит продолжит выделяться и выделяться неправильно.
В моделлинге не шарю, скачал в интернете. Пулемёт нужен не срочно. Кстати, когда я конвертнул модель из mdx в mdl, баг слегка поменялся. При обратном конвертировании вернулся в изначальное состояние. Скрин и модель прилагаются.
прикреплены файлы
Maniac_91 #22 - 2 месяца назад 0
ene241, попробуй рассчитать границы в War3 Model Editor.
ene241 #23 - 2 месяца назад 0
Maniac_91, не помогло, ровно также выделяется
Коля6 #24 - 1 месяц назад 0
король лич нерзул зелёный куб в игре тень
пойму только в видосе
loliconshik3 #25 - 1 месяц назад 0
модель Рем
при загрузке карты с данной моделью вылетает we
loliconshik3:
модель Рем
при загрузке карты с данной моделью вылетает we
пытался что-нибудь сделать в mdvls но т.к. ничего в этом не понимаю, сделал только хуже
прикреплены файлы
Andrey33 #26 - 4 недели назад 0
Кто может сделать collision shapes, трудно навести на модельку мышкой
прикреплены файлы
8gabriel8 #27 - 4 недели назад 0
Andrey33:
Кто может сделать collision shapes, трудно навести на модельку мышкой
Сейчас проверил, нормально модель выделяется и лечится. Может в РО ей какие-то значения так поменял? Для проверки заменил ею модель Чародея крови.
ClotPh #28 - 4 недели назад (отредактировано ) 0
8gabriel8, мной не качалось и не проверялось, но ты во всех возможных ситуациях смотрел? Часто на модель трудно навести, например, в движении или атаке юнита
8gabriel8 #29 - 4 недели назад 0
ClotPh, да, нормально. И такое простым пересчётом границ решается же.
Andrey33 #30 - 4 недели назад (отредактировано ) 0
ClotPh, Особенно в движение.
Например вот эта модель отлично сделана
у лучницы выбор <----> у воина <----------> разница огромная
я проверял на рексаре думал он же большой=)
прикреплены файлы
ledoed #31 - 4 недели назад (отредактировано ) 0
Andrey33:
нужно сделать перерасчет по мешу,делаеть в модель едиторе
Andrey33 #32 - 4 недели назад 0
ledoed, если бы я умел делать я бы не обращался сюда
ledoed #33 - 4 недели назад 1
Andrey33:
ledoed, если бы я умел делать я бы не обращался сюда
починил
прикреплены файлы
Andrey33 #34 - 4 недели назад 0
ledoed, Спасибо большое
Andrey33 #35 - 4 недели назад 0
Сделайте пожалуйста анимацию атаки с луком, а то махает мечом и стрела вылетает, а еще если можно удалите не нужные анимации и удалить меч вообще.
прикреплены файлы
biridius #36 - 4 недели назад (отредактировано ) 1
Andrey33, там же есть две анимации shoot, только и надо что переименовать в Attack, а атакам мечом поставить тег alternate или удалить
прикреплены файлы
Andrey33 #37 - 4 недели назад (отредактировано ) 0
biridius, Спасибо, а как сделать что бы лук был всегда при ней, просто в игре она совсем без лука, только меч весит
biridius #38 - 4 недели назад (отредактировано ) 1
Andrey33, придется рисовать новую ходьбу, стояние с луком есть, щас мб сделаю
надо проверять, вот новая анимация ковыляния, и старое стояние теперь с тегом Alternate, так что должны проигрываться анмации с луком которые Stand Ready
вот, поправил стояние
прикреплены файлы
Andrey33 #39 - 4 недели назад 0
biridius, Спасибо, только она теперь бегает как крадётся и тогда только у ней лук появляется а когда стоит его нету
BattleMaster #40 - 3 недели назад 0
День добрый, не работает модель зилота со священного(тм) воркшопа. Классика: в редакторе куб, в игре - тень.
Качал аналогичные модели с двух сайтов (с вышеупомянутого Воркшопа и с прибежища Сатаны), удалял, импортировал, и повторял все еще несколько раз. Итог - тень и куб.
Модель нужна в кратчайшие строки.
прикреплены файлы
8gabriel8 #41 - 3 недели назад 0
BattleMaster, наверное, что-то не так выставил в РО. Всё нормально отображается:
прикреплены файлы
BattleMaster #42 - 3 недели назад (отредактировано ) 0
8gabriel8:
BattleMaster, наверное, что-то не так выставил в РО. Всё нормально отображается:
хм... я заново удалил все протосское, импортировал зилота. все заработало. Импортировал модель врат, снова что-то сломалось. Может, я лучше пришлю карту?
О, теперь и смысл карты - нексус сломался
прикреплены файлы
8gabriel8 #43 - 3 недели назад 0
BattleMaster, проблемы с текстурами для зилота и врат скорее всего потому, что импортировал одни и те же файлы поверх других. Так не надо делать, если текстура уже есть, то не импортируй её снова. А для нексуса не хватает текстуры ProtossGlow1.blp.
BattleMaster #44 - 2 недели назад 0
8gabriel8:
BattleMaster, проблемы с текстурами для зилота и врат скорее всего потому, что импортировал одни и те же файлы поверх других. Так не надо делать, если текстура уже есть, то не импортируй её снова. А для нексуса не хватает текстуры ProtossGlow1.blp.
Так... и как починить пилон, врата и зилота?
8gabriel8 #45 - 2 недели назад 0
Давай-ка ты мне сам ответишь на этот умный вопрос!)
BattleMaster, помоги! Неправильно импортировал пилон, врата и зилота, что же теперь делать?
BattleMaster #46 - 2 недели назад 0
8gabriel8:
Давай-ка ты мне сам ответишь на этот умный вопрос!)
BattleMaster, помоги! Неправильно импортировал пилон, врата и зилота, что же теперь делать?
Логично предположить, что нужно правильно импортировать файлы, но есть одна проблема... Я не знаю. какие из них создают проблемы. Двойные файлы, если что, я уже удалил.
8gabriel8 #47 - 2 недели назад 0
BattleMaster, просто импортируй файлы по-одному, если файл уже есть, то повторно не импортируй. Проще всего, если ты ПОЛНОСТЬЮ удалил файлы, скопировать файлы из папок с зилоном, вратами и нексусом в одну, а её целиком импортировать.