В 1.29 mdlvis не показывает большинство текстур.
При открытии модели mdlvis не показывает большинство (как импортных, так и стандартных) текстур модели.

Лучший ответ:
Я скачал 1.26а, взял архивы и проверил, с 1.26а mdlvis показывает текстуры. Но из-за некоторых проблем с вариком 1.29 я перешел на 1.30.



Просмотров: 420

8gabriel8 #1 - 5 месяцев назад 0
Путь расположения программы, версия Windows и варика?
Mechanicus #2 - 5 месяцев назад 1
Mdlvis в папке с вариком, варик версии 1.29, Windows 7.
Андреич #3 - 5 месяцев назад 2
конкретно про 1.29 не знаю, но на 1.31 уже не работает млдвис...
я под него держу старую версию варика...
8gabriel8 #4 - 5 месяцев назад 0
По идее в 1.29 убрали Storm.dll, может быть mdlvis её использовал?
Попробуй положить в папку с вариком.
Сначала подумал, что старый mdlvis версии 1.29 пытаешься запустить)
прикреплены файлы
Mechanicus #5 - 5 месяцев назад 0
Storm.dll у меня и так есть, но все равно и с ним не работает.
8gabriel8 #6 - 5 месяцев назад 0
Пробовал другой версии mdlvis? 1.39 или 1.40
Mechanicus #7 - 5 месяцев назад 0
У меня эти версии и стоят.
8gabriel8 #8 - 5 месяцев назад 0
В варике 1.29 ещё mpq-архивы или уже casc?
Mechanicus #9 - 5 месяцев назад 0
Все ещё mpq.
8gabriel8 #10 - 5 месяцев назад 0
Всё-таки подозреваю, что дело в какой-то dll, которую использует mdlvis, так как не видит импортных текстур. Сейчас полистал описание программы и поиском пробежался по интервью с автором, но никакой dll там не упомянуто, хотя вроде бы где-то об этом читал, наверное, в одном из комментариев к программе упомянуто)
war 3 model editor нормально работает?
Mechanicus #11 - 5 месяцев назад 1
Дело не только в импортных текстурах, mdlvis и стандартные не все видит.
8gabriel8 #12 - 5 месяцев назад 0
Если бы не видел только стандартные, то проблема в mpq, если не видит и импортные, то не в mpq)
Точнее может и в mpq, но вряд ли.
Mechanicus #13 - 5 месяцев назад 1
Возможно дело в mpq, я выташил из архива несколько моделей и открыл их mdlvis'ом. Все текстуры которые mdlvis показал находятся в UI.
8gabriel8 #14 - 5 месяцев назад 0
8gabriel8:
war 3 model editor нормально работает?
Mechanicus #15 - 5 месяцев назад 2
War 3 model editor нормально работает.
8gabriel8 #16 - 5 месяцев назад 0
Когда это началось?
и попробуй всё-таки мою storm.dll
Mechanicus #17 - 5 месяцев назад 1
Проблемы с текстурами были с момента установки mdlvis'а на 1.29. Помню, устанавливал раньше 1.29, но проблема с текстурами решалась добавлением необходимых текстур в папку с моделью. Да и ошибка говорила об необходимых текстурах, а не "Не удалось распаковать BLP". Попробовал твою Storm.dll - ничего не изменилось.
8gabriel8 #18 - 5 месяцев назад 0
У меня было что-то такое, когда переустанавливал ОС. В одном случае вроде как раз с текстурами что-то пришло в норму само собой через несколько дней, в другом с пунктом открытия модели через mdlvis в контекстным меню так и не пришло, пока ноутбук не сменил. Потому попробуй почистить в реестре данные о mdlvis, полностью выключить и включить компьютер, опять mdlvis запустить. Потому что на сбой похоже, раз раньше такой ошибки не возникало.
Mechanicus #19 - 5 месяцев назад 1
Нет, все-таки проблема в mpq. Я попробовал запустить mdlvis без mpq и mdlvis вместо "Не удалось распаковать BLP" стал требовать конкретные текстуры, проблема все-таки была в mpq. И я вот что решил, если mdlvis не показывает текстуры с архивами варика 1.29, то с архивами, например, варика 1.26 должен.
8gabriel8 #20 - 5 месяцев назад 0
Но тогда странно, что на war 3 model editor это не повлияло.
Mechanicus #21 - 5 месяцев назад 2
Странно, но возможно иного решения нет.
8gabriel8 #22 - 5 месяцев назад 1
Сообщи, помогут ли mpq от 1.26а.
Mechanicus #23 - 4 месяца назад 2

Я скачал 1.26а, взял архивы и проверил, с 1.26а mdlvis показывает текстуры. Но из-за некоторых проблем с вариком 1.29 я перешел на 1.30.