Хелп триггер не работает (GUI)
Суть такова сделал 3 триггера что бы мобы бегали за тобой как в жизни на арене , вроде сделал все правильно , но нечего не работает

Без ответа.


Просмотров: 142

Wadimiru #1 - 1 неделю назад 0
У них не хватает дистанции получения приказа.
Выстави достаточное значение и все будет работать.
Solo #2 - 1 неделю назад 0
Wadimiru, Выставил, триггер не работает мобы бегут секунды 2-3 , а потом на исходную точку и так по кругу
Andrey33 #3 - 1 неделю назад 1
Solo #4 - 1 неделю назад 0
Andrey33, я же говорю триггер не работает ,если поставить дистанцию получения то они бегут 2-3 секунды , и потом назад , а мне надо что бы они по всей карте бегали и атаковали не бегая к исходной точке
dave_wwid #5 - 1 неделю назад 0
Если используешь нейтрально-враждебного игрока, то естественно будут проблемы. Попробуй изменить (значительно увеличить) в константах - монстры время возвращения охраны + монстры расстояние охраны (так это переведено в русском редакторе).
Wadimiru #6 - 1 неделю назад 0
Solo, А там у тебя проблема с определением точки, которую атаковать.
Хотя я бы предпочел использовать просто группу, добавлять в нее героев при найме. При выборе рандомного юнита из этой группы - проверять - находится ли он в боевой зоне (Если при смерти может быть респаун на фонтане с закрытым доступом к арене, например) и жив ли он.
Только что проверил под такую схему - прекрасно работает.
dave_wwid, У него проблема в том, что там вообще все три триггера надо переписывать с нуля. Там такой индусский код, что это нечто.
dave_wwid #7 - 1 неделю назад 0
Игрок 12- нейтрально-враждебный. Меняем константы Wadimiru, ничего там индусского нет, поверьте
прикреплены файлы