Скаченная модель не отображается после Build
Есть модель в формате .obj. При импорте в юните все прекрасно отображается, даже после запуска сцены (эмуляции игры).
Но как только я компилирую игру под android - в игре она не отображается.
Многое пробовал: замена текстур на shader legacy, отключение GPU Skinning в настройках Build - не помогает.
Другие скаченные мною модели отображаются, поэтому я подумал, что дело именно в этой, и скачал еще одну подобной тематики: тот же результат.
Думаю, что возможна проблема в мешах, но я в моделях ничего не понимаю.
Вот ссылка на модель: free3d.com/ru/3d-model/zeus-v1--499854.html
Мб кто сталкивался или хорошо в них разбирается, ну или просто самый крутой парень на свете - сможет помочь мне.
////
use 32-bit display = disabled
disable depth and stencil = enabled
по итогу отображаться перестали вообще все модели



Views: 752

TeX13 #1 - 2 years ago 0
Голосов: +0 / -0
Я так понял проблема возникает, когда я пытаюсь использовать модель с большим количеством вершин

В компиляции под Windows - все прекрасно работает.
TeX13 #2 - 2 years ago 0
Голосов: +0 / -0
Решение было найдено: я использовал bluestack 3+ для эмуляции. При запуске на своем телефоне - все отображается, без каких-либо галочек (стандартный кфг). Но всплывает другой вопрос, будут ли проблемы отображения в других системах Андроид, ведь мб в эмуляторе не отображается по причине другой версии ОС? (((
Clamp #3 - 2 years ago 2
Голосов: +2 / -0
Какой режим рендера установлен в эмуляторе, DirectX или OpenGL?
Если первое, то меняй на второе, на телефонах DirectX не завезли.
TeX13 #4 - 2 years ago 0
Голосов: +0 / -0
Clamp, прошу прощения за столь поздний ответ. Стоит OpenGL. К слову на Bluestakc 4+ все отображается без проблем, только вот компьютер мой его не вывозит((( приходиться прибегать к помощи ноутбука