Глючит лента новостей при обновлении ресурса
Сама лента новостей глючила давно, у меня периодически пропадал мой ресурс в ленте новостей, при переходе на вторую страницу. Не соврать бы, целый год, уже как. Никто даже не почесался, думаю, что и с теперешней проблемой будет также, более того, непонятно к кому обращаться с этим вопросом. Итак, суть проблемы, при обновлении ресурса он появляется не в начале ленты новостей, а строго в начале третьей страницы ленты новостей, что иллюстирует прикреплённый мною к сообщению скрин. Вопрос к знатокам, что в чёрном ящике? как быть с такой ситуёвиной дальше, может, кто-то уже решал такой вопрос?

Лучший ответ:
Было выявлено, что при отсутствии комментов неправильная логика работы

UP: При скрытии нашёл проблему. Если у вас нет прав на скрытие ресурса, он скрывался при редактировании

UP: Проверяем



Просмотров: 2 979

Obelick #1 - 2 года назад 0
Да, уже очень давно есть такая проблема когда дополняешь свое последнее сообщение, тред поднимается наверх страницы, на котором было, а не на первую. Нужно чтобы новый человек отписался в треде, тогда он апнется.
koloff #2 - 2 года назад 0
Нужно чтобы новый человек отписался в треде, тогда он апнется.
Эвоно как! Друзья, кому будет не унизительно, черкните что-нибудь в этом ресурсе, хоть точку поставьте, что бы проверить это. Может, так оно и есть, но 100%, до этого вечера у меня такого не было не разу.
ScorpioT1000 #3 - 2 года назад 0
Нормально, здесь пока оставляй открытым. Будем иметь ввиду.
ScorpioT1000 #4 - 2 года назад (отредактировано ) 0
koloff, опиши, плиз, шаги к воспроизведению и ссылку на ресурс. При обновлении ставится галка "поднять ресурс"?
koloff #5 - 2 года назад 0
Так что писать-то? Любой мой ресурс из проекта "Древние Свитки", или пропадает при переходе на вторую страницу ленты новостей, помогает только новый коммент (но тут модеры не довольны). Пару раз застревание было в произвольных местах. Помогает опять же новый коммент, но опять же модеры недовольны.
ScorpioT1000 #6 - 2 года назад (отредактировано ) 0
koloff, я разберусь скоро, сейчас смотрел, вроде всё верно. Мне кажется, что пропадает после публикации. У тебя щас 3 уровень, так? Можешь проверить сам, опубликовав его заново (снять с публикации - потом опубликовать)?
koloff #7 - 2 года назад (отредактировано ) 0
ScorpioT1000, Это баг не только у меня встречается, я знаю, как минимум, ещё одного человека с такой же бедой. Думаю, что многие просто и не замечали, что их ресурсы пропадают при переходе на новую страницу ленты новостей. Сейчас попробую проделать то, что просишь.
ScorpioT1000:
снять с публикации - потом опубликовать
Сделал, при снятии с публикации - ресурс пропал с ленты новостей, при публикации - появился, правда, не в начале, а ближе к концу, или это нормально?
Да, галку "поднять ресурс" - ставил.
ScorpioT1000 #8 - 2 года назад 0
koloff, короче, пока разбираюсь. Я так то видел, что "свиток" пропал, было 2 до этого. Но пока не пойму, из-за чего

Разобрался. Проблема была в том, что если ресурс был утверждён, но у него есть новая неутверждённая версия, эта версия появлялась в feed.
Теперь такие ресурсы не появятся.
А те старые не были в ленте, т.к. их срок публикации довольно давний.

Исправление тестируется, дальше только будет доставлено на основной сервер. Следите за обновлениями в новостях.
koloff #9 - 2 года назад 0
Не знаю, важно это или нет, но после выше описаных манипуляций, ресурс благополучно перескочил на вторую страницу, когда постепенно доехал до конца первой. И кстати, я сегодня-завтра, буду создавать новый ресурс с нуля, под пятый свиток. Может, это как-то пригодиться?
Эм, блин, одновременно добавились два наших комента, если всё уже в поряде, на мой последний можно не обращать внимания.
koloff #10 - 2 года назад 0
ScorpioT1000, Всё ещё не работает=( Ночью создал ресурс под пятый свиток, так вот, он тоже пропал с ленты новостей, при переходе на её вторую страницу.
ScorpioT1000 #11 - 2 года назад 0
Исправление тестируется, дальше только будет доставлено на основной сервер. Следите за обновлениями в новостях.
Сейчас, кстати, можешь проверять
koloff #12 - 2 года назад 2   
ScorpioT1000, Сейчас попробую, ресурс уже пропал и не появился вновь, комент шлёпну сейчас, надеюсь, всё будет в поряде.
ScorpioT1000, ресурс благополучно перескочил на вторую страницу, когда постепенно доехал до конца первой. Понаблюдаю ещё, если что, здесь же и отпишусь.
ScorpioT1000, Не знаю, смеяться или плакать, но теперь этот ресурс перескочил на вторую страницу ленты новостей, вместо её самого начала, когда я тиснул предыдущий комент=(
Прикрепленные файлы
ScorpioT1000 #13 - 2 года назад 0
Там гдето сортировка по дате последнего коммента. Я пока не могу заниматься, но ответ сниму. Продолжу расследовать на след. неделе
koloff #14 - 2 года назад 0
Так и пропадают ресурсы, при переходе на вторую страницу ленты новостей. Вчера создал новый ресурс под 6 свиток - пропал.
ScorpioT1000 #15 - 2 года назад 0
Что там короче, все свитки нашлись?)
Obelick #16 - 1 год назад 0
Только что создал похожий вопрос в техподдержку, но его видимо бот почистил или еще кто. Все так же не работает.
Прикрепленные файлы
koloff #17 - 1 год назад 0
Obelick, Нужно собирать подписи на петицию, похоже. Иначе не будет толку.
PT153 #18 - 1 год назад (отредактировано ) 0
Проблема действительно есть.
Первая картинка является скриншотом ленты комментариев. Обведённый вопрос пропал из ленты проектов (оставшиеся 2 картинки).
Прикрепленные файлы
PT153 #19 - 1 год назад (отредактировано ) 0
ScorpioT1000 #20 - 1 год назад 0
PT153, где этот пост, его скрыли, я так понял?
8gabriel8 #21 - 1 год назад 0
PT153 #22 - 1 год назад 0
где этот пост, его скрыли, я так понял?
Ты про мой последний комментарий? Пост есть.
koloff #23 - 1 год назад 2   
PT153, Не будет толку всё равно, хотели бы, уже давно пофиксили бы...
ScorpioT1000 #24 - 1 год назад 0
koloff, лучше откроем донат на найм разработчика)
PT153 #25 - 1 год назад 2   
Прикрепленные файлы
ScorpioT1000 #26 - 10 месяцев назад 0
Ап, ошибка воспроизводится?
ScorpioT1000 #28 - 5 месяцев назад 0
Я никак не могу воспроизвести. Ни с комментами, ни с премодерацией. Дайте шаги кто-нибудь, как это протестить?
PT153 #29 - 5 месяцев назад 0
А вот не знаю. Просто как-то так выходит.
PT153 #30 - 3 месяца назад 0
Этот вопрос пропал из ленты проектов, в комментариях есть.
Niken #31 - 3 месяца назад (отредактировано ) 0
Багуется с отображение первых 2 ресурса на второй странице
Прикрепленные файлы
ScorpioT1000 #32 - 3 месяца назад (отредактировано ) 0
Нашёл логическую ошибку, проверяем фикс
PT153 #33 - 2 месяца назад (отредактировано ) 0
Баг есть.
Пропал вопрос "перемещение ресурса в ленте при склейке комментариев".
Прикрепленные файлы
ScorpioT1000 #34 - 1 месяц назад 0
UP: Проблема появляется вообще при отсутствии комментов, если скрыть-показать вопрос
Proshel_Doty #35 - 1 месяц назад (отредактировано ) 0
ScorpioT1000:
UP: Проблема появляется вообще при отсутствии комментов, если скрыть-показать вопрос
Точно? Я вот создал новый вопрос, и я не могу его скрыть или показать - xgm.guru/p/xgm/240521/comments?postid=440878#comment23
С тем по хоже было тоже самое, потому что я не помню, чтобы там было что-то про то что можно поставить галочку. Сначала я подумал, мб и правда не заметил. Но по ходу её не было
А то, что её не было до того как Мзей открыл его, это 100%
Это сообщение удалено
ScorpioT1000 #37 - 1 месяц назад 0

Было выявлено, что при отсутствии комментов неправильная логика работы

UP: При скрытии нашёл проблему. Если у вас нет прав на скрытие ресурса, он скрывался при редактировании

UP: Проверяем